use strict;
my $str = '2:5
4:15
21:26
14:7
8:2
';
my $regex = qr/(^|\D)(\d)($|\D)/mp;
my $subst = '$10$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";