// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|\D)(\d)($|\D)").unwrap();
let string = "2:5
4:15
21:26
14:7
8:2
";
let substitution = "$10$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}