$re = '/(^|\D)(\d)($|\D)/m';
$str = '2:5
4:15
21:26
14:7
8:2
';
$subst = "$10$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;