const regex = /(^|\D)(\d)($|\D)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\D)(\\d)($|\\D)', 'gm')
const str = `2:5
4:15
21:26
14:7
8:2
`;
const subst = `$10$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);