import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(@\\)";
final String string = "TheEuropean(@)languages(@)are(@)members(@)of(@)the(@)same(@)family\n"
+ ".Their(@)separate(@)existence(@)isamyth.(@)For(@)science,music,\n"
+ "sport,etc,Europeusesthe(@)same(@)vocabulary.Thelanguages(@)only(@)d\n"
+ "iffer(@)in(@)their(@)grammar,their(@)pronunciation(@)andtheirmostcommon\n"
+ "words.Everyonerealizeswhyanewcommonlanguagewouldbedesirable:onecould\n"
+ "refusetopayexpensivetranslators.";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}