#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{(?:[^{}]|(?R))*\}"
Local $sString = "{" & @CRLF & _
" "title": "This is a a test }"," & @CRLF & _
" "date": "2017-11-16T20:47:16+00:00"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"This is a a test }" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")