$re = '/\{(?:[^{}]|(?R))*\}/';
$str = '{
"title": "This is a a test }",
"date": "2017-11-16T20:47:16+00:00"
}
This is a a test }
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);