re = /\{(?:[^{}]|(?R))*\}/
str = '{
"title": "This is a a test }",
"date": "2017-11-16T20:47:16+00:00"
}
This is a a test }
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end