// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{(?:[^{}]|(?R))*\}").unwrap();
let string = "{
\"title\": \"This is a a test }\",
\"date\": \"2017-11-16T20:47:16+00:00\"
}
This is a a test }
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}