import re
regex = re.compile(r"\{(?:[^{}]|(?R))*\}")
test_str = ("{\n"
" \"title\": \"This is a a test }\",\n"
" \"date\": \"2017-11-16T20:47:16+00:00\"\n"
"}\n\n"
"This is a a test }\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")