import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?:[^\\{\\}]|(?R))*\\}";
final String string = "{\n"
+ " \"title\": \"This is a a test }\",\n"
+ " \"date\": \"2017-11-16T20:47:16+00:00\"\n"
+ "}\n\n"
+ "This is a a test }\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}