# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)[^\/]+\/?$/\1/gm;t' <<< "https://domain.com/tags/js/
https://domain.com/dir/negotiations/chi
https://domain.com/ask/parent/quest/pr/"