const regex = new RegExp('(.*?)[^/]+/?$', 'gm')
const str = `https://domain.com/tags/js/
https://domain.com/dir/negotiations/chi
https://domain.com/ask/parent/quest/pr/`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);