import Foundation
let pattern = #"(.*?)[^/]+/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://domain.com/tags/js/
https://domain.com/dir/negotiations/chi
https://domain.com/ask/parent/quest/pr/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)