$re = '~(.*?)[^/]+/?$~m';
$str = 'https://domain.com/tags/js/
https://domain.com/dir/negotiations/chi
https://domain.com/ask/parent/quest/pr/';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;