using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)[^/]+/?$";
string substitution = @"\1";
string input = @"https://domain.com/tags/js/
https://domain.com/dir/negotiations/chi
https://domain.com/ask/parent/quest/pr/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}