package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)[^/]+/?$`)
var str = `https://domain.com/tags/js/
https://domain.com/dir/negotiations/chi
https://domain.com/ask/parent/quest/pr/`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}