#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*?)[^/]+/?$"
Local $sString = "https://domain.com/tags/js/" & @CRLF & _
"https://domain.com/dir/negotiations/chi" & @CRLF & _
"https://domain.com/ask/parent/quest/pr/"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)