re = /(.*?)[^\/]+\/?$/m
str = 'https://domain.com/tags/js/
https://domain.com/dir/negotiations/chi
https://domain.com/ask/parent/quest/pr/'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result