package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z][A-Z0-9]?\b`)
var str = `Height of Building code J 9.5m
Height of Building code T1 26.0m
Height of Buildings O=16 Metres
Maximum Building Height (RL m) 50m`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}