// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z][A-Z0-9]?\b").unwrap();
let string = "Height of Building code J 9.5m
Height of Building code T1 26.0m
Height of Buildings O=16 Metres
Maximum Building Height (RL m) 50m";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}