re = /\b[A-Z][A-Z0-9]?\b/m
str = 'Height of Building code J 9.5m
Height of Building code T1 26.0m
Height of Buildings O=16 Metres
Maximum Building Height (RL m) 50m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end