const regex = /\b[A-Z][A-Z0-9]?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z][A-Z0-9]?\\b', 'gm')
const str = `Height of Building code J 9.5m
Height of Building code T1 26.0m
Height of Buildings O=16 Metres
Maximum Building Height (RL m) 50m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}