#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(teste = ""[\s\S]*?<\/cfscript>)"
Local $sString = "<cfscript>" & @CRLF & _
" this.someThing(" & @CRLF & _
" ..." & @CRLF & _
" teste = "" # I want to find by here" & @CRLF & _
"" & @CRLF & _
" );" & @CRLF & _
"</cfscript>" & @CRLF & _
"" & @CRLF & _
"<cfscript>" & @CRLF & _
" this.someThing(" & @CRLF & _
" );" & @CRLF & _
"</cfscript>" & @CRLF & _
"" & @CRLF & _
"<cfscript>" & @CRLF & _
" this.someThing(" & @CRLF & _
" ..." & @CRLF & _
" teste = "" # I want to find by here" & @CRLF & _
"" & @CRLF & _
" );" & @CRLF & _
"</cfscript>"
Local $sSubst = "\1\n@@@"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)