re = /(teste = ""[\s\S]*?<\/cfscript>)/m
str = '<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>
<cfscript>
this.someThing(
);
</cfscript>
<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>'
subst = '\\1\\n@@@'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result