$re = '/(teste = ""[\s\S]*?<\/cfscript>)/m';
$str = '<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>
<cfscript>
this.someThing(
);
</cfscript>
<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>';
$subst = "\1\n@@@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;