const regex = /(teste = ""[\s\S]*?<\/cfscript>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(teste = ""[\\s\\S]*?<\\\/cfscript>)', 'gm')
const str = `<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>
<cfscript>
this.someThing(
);
</cfscript>
<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>`;
const subst = `\1\n@@@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);