import re
regex = re.compile(r"(teste = \"\"[\s\S]*?<\/cfscript>)", flags=re.MULTILINE)
test_str = ("<cfscript>\n"
" this.someThing(\n"
" ...\n"
" teste = \"\" # I want to find by here\n\n"
" );\n"
"</cfscript>\n\n"
"<cfscript>\n"
" this.someThing(\n"
" );\n"
"</cfscript>\n\n"
"<cfscript>\n"
" this.someThing(\n"
" ...\n"
" teste = \"\" # I want to find by here\n\n"
" );\n"
"</cfscript>")
subst = "\\1\\n@@@"
result = regex.sub(subst, test_str)
if result:
print(result)