// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(teste = ""[\s\S]*?<\/cfscript>)"#).unwrap();
let string = "<cfscript>
this.someThing(
...
teste = \"\" # I want to find by here
);
</cfscript>
<cfscript>
this.someThing(
);
</cfscript>
<cfscript>
this.someThing(
...
teste = \"\" # I want to find by here
);
</cfscript>";
let substitution = "\\1\\n@@@";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}