import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(teste = \"\"[\\s\\S]*?<\\/cfscript>)";
final String string = "<cfscript>\n"
+ " this.someThing(\n"
+ " ...\n"
+ " teste = \"\" # I want to find by here\n\n"
+ " );\n"
+ "</cfscript>\n\n"
+ "<cfscript>\n"
+ " this.someThing(\n"
+ " );\n"
+ "</cfscript>\n\n"
+ "<cfscript>\n"
+ " this.someThing(\n"
+ " ...\n"
+ " teste = \"\" # I want to find by here\n\n"
+ " );\n"
+ "</cfscript>";
final String subst = "\\1\\n@@@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}