using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(teste = ""[\s\S]*?<\/cfscript>)";
string substitution = @"\1\n@@@";
string input = @"<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>
<cfscript>
this.someThing(
);
</cfscript>
<cfscript>
this.someThing(
...
teste = "" # I want to find by here
);
</cfscript>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}