#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[0-9]{1,2}.)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})"
Local $sString = "178.33.37.215:9999" & @CRLF & _
"213.136.87.38:8118" & @CRLF & _
"139.5.71.126:23500" & @CRLF & _
"138.201.223.250:31288"
Local $sSubst = ""$1:$2";"2019-05-17""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)