import re
regex = re.compile(r"(^[0-9]{1,2}.)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})", flags=re.MULTILINE)
test_str = ("178.33.37.215:9999\n"
"213.136.87.38:8118\n"
"139.5.71.126:23500\n"
"138.201.223.250:31288")
subst = "\"$1:$2\";\"2019-05-17\""
result = regex.sub(subst, test_str)
if result:
print(result)