# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<tag>|\G(?!\A))[^<]*?\Kсобака//g;t' <<< "корова собака бык
<tag>корова собака бык собака петух конь собака</tag>
корова собака бык
"