#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<tag>|\G(?!\A))[^<]*?\Kсобака"
Local $sString = "корова собака бык" & @CRLF & _
"<tag>корова собака бык собака петух конь собака</tag>" & @CRLF & _
"корова собака бык" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)