use strict;
my $str = 'корова собака бык
<tag>корова собака бык собака петух конь собака</tag>
корова собака бык
';
my $regex = qr/(<tag>|\G(?!\A))[^<]*?\Kсобака/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";