$re = '/(<tag>|\G(?!\A))[^<]*?\Kсобака/';
$str = 'корова собака бык
<tag>корова собака бык собака петух конь собака</tag>
корова собака бык
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;