using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<tag>|\G(?!\A))[^<]*?\Kсобака";
string substitution = @"";
string input = @"корова собака бык
<tag>корова собака бык собака петух конь собака</tag>
корова собака бык
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}