import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<tag>|\\G(?!\\A))[^<]*?\\Kсобака";
final String string = "корова собака бык\n"
+ "<tag>корова собака бык собака петух конь собака</tag>\n"
+ "корова собака бык\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}