import Foundation
let pattern = #"(<tag>|\G(?!\A))[^<]*?\Kсобака"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
корова собака бык
<tag>корова собака бык собака петух конь собака</tag>
корова собака бык
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)