re = /(<tag>|\G(?!\A))[^<]*?\Kсобака/
str = 'корова собака бык
<tag>корова собака бык собака петух конь собака</tag>
корова собака бык
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result