#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+-]?(\d+(\.\d+)?|\.\d+)"
Local $sString = "123" & @CRLF & _
"23.45" & @CRLF & _
"34." & @CRLF & _
".45" & @CRLF & _
"-123" & @CRLF & _
"-273.15" & @CRLF & _
"-42." & @CRLF & _
"-.45" & @CRLF & _
"+516" & @CRLF & _
"+9.8" & @CRLF & _
"+2." & @CRLF & _
"+.5" & @CRLF & _
"." & @CRLF & _
"-." & @CRLF & _
"+." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")