import re
regex = re.compile(r"[+-]?(\d+(\.\d+)?|\.\d+)", flags=re.MULTILINE)
test_str = ("123\n"
"23.45\n"
"34.\n"
".45\n"
"-123\n"
"-273.15\n"
"-42.\n"
"-.45\n"
"+516\n"
"+9.8\n"
"+2.\n"
"+.5\n"
".\n"
"-.\n"
"+.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")