$re = '/[+-]?(\d+(\.\d+)?|\.\d+)/m';
$str = '123
23.45
34.
.45
-123
-273.15
-42.
-.45
+516
+9.8
+2.
+.5
.
-.
+.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);