import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+-]?(\\d+(\\.\\d+)?|\\.\\d+)";
final String string = "123\n"
+ "23.45\n"
+ "34.\n"
+ ".45\n"
+ "-123\n"
+ "-273.15\n"
+ "-42.\n"
+ "-.45\n"
+ "+516\n"
+ "+9.8\n"
+ "+2.\n"
+ "+.5\n"
+ ".\n"
+ "-.\n"
+ "+.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}