re = /[+-]?(\d+(\.\d+)?|\.\d+)/m
str = '123
23.45
34.
.45
-123
-273.15
-42.
-.45
+516
+9.8
+2.
+.5
.
-.
+.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end