// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[+-]?(\d+(\.\d+)?|\.\d+)").unwrap();
let string = "123
23.45
34.
.45
-123
-273.15
-42.
-.45
+516
+9.8
+2.
+.5
.
-.
+.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}