package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[+-]?(\d+(\.\d+)?|\.\d+)`)
var str = `123
23.45
34.
.45
-123
-273.15
-42.
-.45
+516
+9.8
+2.
+.5
.
-.
+.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}