using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?(\d+(\.\d+)?|\.\d+)";
string input = @"123
23.45
34.
.45
-123
-273.15
-42.
-.45
+516
+9.8
+2.
+.5
.
-.
+.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}