# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[caption[^]]+]\R?//g;t' <<< "[caption id=\"attachment_24612\" align=\"alignnone\" width=\"900\"]
Other text"